결제오류 9502에 대한 조치 - PGALL - 워드프레스 결제는 한번에
Menu

워드프레스 결제 게시판 포럼 – PGALL 워드프레스 결제 NHN KCP 결제오류 9502에 대한 조치

SimplePay PGALL Review

포럼 - 결제 서비스 이용 중 궁금하신 사항 및 아이디어를 남겨 주세요.

이 게시글은 1개 답변과 2명 참여가 있으며 마지막으로  코드엠에 의해 1 년, 7 월 전에 업데이트 됐습니다.

2 글 보임 - 1 에서 2 까지 (총 2 중에서)
  • 글쓴이
  • #27453

    KCP 플러그인을 설치하여 코드부여받고 세팅을 다 하고 결제를 했는데 9502번 마지막 오류가 나서 KCP에 기술문의 하고 호스팅업체에 문의한 결과 다운받은 모듈이 32bit라 그런다네요..
    64bit기반 모듈로 변경하면 해결된다고 하는데,,어디서 다운받아야 하는지 아니면 다른 기술적인 문제가 있는건지 답변 부탁드립니다.

    (kcp 답변)
    안녕하세요. NHN KCP 기술지원팀입니다.

    9502 오류는 해당 서버와 KCP 간의 소켓통신하는 파일(bin\pp_cli)이
    정상적으로 실행되지 않았을 때 발생하는 오류 입니다.

    확인할 사항 전달드리니 아래 내용 확인 부탁드립니다.

    1. 업체 서버 비트에 맞는 pp_cli 실행파일을 Binary타입으로 서버에 업로드

    2. 업로드 후 pp_cli 실행파일에 755 권한 부여

    3. site_conf_inc 환경설정 페이지에 g_conf_home_dir 변수에 pp_cli 절대경로 입력
    (bin폴더 앞까지)
    예) g_conf_home_dir = “/local_home/kcp/sample/payplus”;

    쉘 접속이 가능하다면, 아래 내용 추가로 확인해보시기 바랍니다.

    1. pp_cli파일 권한 설정 후, 쉘에서 pp_cli –h 입력 후 나오는 메세지 확인부탁드립니다.

    예)[root@cisco.co.kr:/kcp/sample/payplus/bin]./pp_cli –h

    위와 같이 실행 후 아래와같은 메세지가 나오면 정상입니다.
    res_cd=S102res_msg=연동 모듈 호출 오류

    2. 쉘에서 pwd 입력 후 나오는 현재 로컬경로를 복사하여
    site_conf_inc 페이지에 $g_conf_home_dir 변수에 입력해주시기 바랍니다.
    (경로가 bin까지 추출될 경우 bin은 제외하고 입력해주세요.)

    예)[root@cisco.co.kr:/kcp/sample/payplus/bin]pwd
    /local_home/kcp/sample/payplus/bin

    $g_conf_home_dir = “/local_home/kcp/sample/payplus”;

    감사합니다.

    (카페24답변)
    안녕하세요.
    카페24 호스팅센터입니다.

    pp_cli의 경로를 체크해 보니 kcp 우커머스 플러그인 경로 내 존재하는 것으로 확인 됩니다.

    www/wp-content/plugins/kcp-for-woocommerce-ex/lib/bin

    해당 경로로 접근하여 확인시 별도의 실행권한을 허용해 놓지 않으신 것으로 확인되어 755 권한을 넣어 드렸습니다.
    다만 해당 pp_cli 실행시 다음과 같은 오류가 발생하는데 서버 환경에 맞지 않는 모듈 파일로 확인 됩니다.

    ./pp_cli: /lib/ld-linux.so.2: bad ELF interpreter

    해당 모듈은 32bit용 모듈로 확인되는데 고객 님께서 사용하는 서버 환경은 64bit 환경으로 제공하고 있으니 64bit용 플러그인 / 모듈로 교체하여 확인해 보시기 바랍니다.

    ]# file pp_cli

    pp_cli: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped

    서버환경

    linux 64bit

    php 버전 : PHP 7.0.0p1

    glibc 버전 : glibc 2.17

    다른 문의가 있으시면 언제든지 게시판으로 문의주시기 바랍니다.
    성심성의껏 안내해 드리겠습니다.

    감사합니다.

    #27455

    코드엠
    Keymaster

    안녕하세요. 코드엠샵입니다.

    64비트용 pp_cli 파일을 첨부로 보내드립니다.

    파일 업로드 후 다시 한번 확인을 부탁드립니다.

    감사합니다.

    • 이 답변은  코드엠에 의해 1 년, 7 월 전에 수정됐습니다.
    Attachments:
    You must be logged in to view attached files.
2 글 보임 - 1 에서 2 까지 (총 2 중에서)

답변은 로그인 후 가능합니다.